almost 7 years ago

目前的mininet裡的ovs仍是2.0.2

如果你有任何需要想要更新,可以依下列流程更新

  • 但如果你想要用OpenFlow1.3建議還是用目前mininet2.0.2的,目前測試升上去後與OPF1.3控制器連線時會有問題,可以connect但無法正常對談,但還不知為什麼(2014/10初測試)
    $ git clone git://github.com/mininet/mininet
    $ ./mininet/util/install.sh -a
    //刪除原本的ovs套件
    $ aptitude remove openvswitch-common openvswitch-datapath-dkms openvswitch-controller openvswitch-pki openvswitch-switch -y
    //安裝新版的ovs套件
    $ wget http://openvswitch.org/releases/openvswitch-2.3.0.tar.gz
    $ tar zxvf openvswitch-2.3.0.tar.gz
    $ cd openvswitch-2.3.0
    $ ./configure --prefix=/usr --with-linux=/lib/modules/uname -r/build
    $ make
    $ sudo make install
    $ sudo make modules_install
    $ sudo rmmod openvswitch
    $ sudo depmod -a
    $ sudo /etc/init.d/openvswitch-controller stop
    $ sudo update-rc.d openvswitch-controller disable
    $ sudo /etc/init.d/openvswitch-switch start
    

參考來源

roan's blog

← fedora updata or install error. Cannot retrieve metalink for repository When running OpenDayLight, the console appear OutOfMemoryError: PermGen space →