almost 7 years ago

如果你fedora在更新或安裝新程式的時候遇到了以下的問題

Loaded plugins: langpacks, refresh-packagekit
Error: Cannot retrieve metalink for repository: fedora/20/i386. Please verify its path and try again

此時可依照下列步驟更新你的認證

  1. 刪除有關https的更新站
    # vi /etc/yum.repos.d/fedora.repo
    //把所有https 換成 http
    # vi /etc/yum.repos.d/fedora-updates.repo
    //把所有https 換成 http
    
  2. 安裝新憑證
    # yum update ca-certificates
    //or 
    # yum reinstall ca-certificates
    
    3.改回原本的https
    # vi /etc/yum.repos.d/fedora.repo
    //將剛剛改的http改回https,開頭應該是mirrorlist
    # vi /etc/yum.repos.d/fedora-updates.repo
    //將剛剛改的http改回https,開頭應該是mirrorlist
    
    以上步驟即可完成更新認證
← estinet8.1 installation + setting environment in emulation mode with openflow1.3 update ovs to 2.3.0 in mininet →